Up to top level
AO15   AO16   AO17   AO18   Backgrounds   Calibration   Conference   Data   Docs   EPICMOS   EPICpn   Feedback   Gallery   Misc   OM   Pending   PhD_Theses   Publications   RGS   RadMonitor   SAS_Hardware   SAS_WS   SASv16.0   SASv16.0_Installation   SASv16.1   SASv16.1_Installation   SASv17.0   SASv17.0_Installation   SciSim   Simulators_other   Suggestions   Trash   Visibility   XMM-bouncing   XMM-news   XRPS   XSA   esas   incoming  

Logged in as guest

Viewing SASv17.0_Installation/83741
Full headers

From: pere.munar@uab.cat
Subject: sas 17 installation
Compose reply
Download message
Move To:
2 replies: 1 2
0 followups:

Private message: yes  no

Notes:

Notification:


Date: Wed, 25 Jul 2018 13:01:18 GMT
From: pere.munar@uab.cat
To: xmmhelp@sciops.esa.int
CC: pere.munar@uab.cat
Subject: sas 17 installation
Full_Name: Pere Munar-Adrover
Submission from: (NULL) (193.147.152.102)


Dear helpdesk team,

I am experiencing some problems when installing SAS version 17.0.0: I am trying
to install it on a Fedora 27 machine with 64 bits intel processor and 16 Gb
RAM.

I downloaded both the RedHat and th Ubuntu binaries (sas_17.0.0-RHEL6.8-64 and
sas_17.0.0-Ubuntu16.04-64). But with both I end up in the same place: when
running the installation script it enters what seems an infinite loop (I let if
for hours and it did not finish installing) in which it says the following, over
and over again (look at the botton of the message).

I do not know what can I try.

Can you give me some advice?

Thanks a lot!

Regards,

Pere

This is the message that appears over and over:


	Downloading Python modules needed for SAS from Conda repositories ...
	..................^C/home/pmunar/bin/sas_17.0.0-RHEL6.8-64/xmmsas_20180620_1732/pythonInstaller/miniconda_and_env_installer.sh:
l.nia 147: kill: (11999) - No such process
done
	!!! Some needed Python pkgs are missing unedr the environment: sas_17.0.0.
Exiting !!! 
	Ready to install the correct Python environment for SAS ...
	(Python env sas_17.0.0 will be removed and re-installed for the correct one)

Package plan for package removal in environment
/home/pmunar/bin/sas_17.0.0-RHEL6.8-64/xmmsas_20180620_1732/miniconda3/envs/sas_17.0.0:

The following packages will be REMOVED:

    asn1crypto:       0.24.0-py36_0        
    astropy:          2.0.1-np113py36_0    
    atomicwrites:     1.1.5-py36_0         
    attrs:            18.1.0-py36_0        
    ca-certificates:  2018.03.07-0         
    certifi:          2018.4.16-py36_0     
    cffi:             1.11.5-py36h9745a5d_0
    chardet:          3.0.4-py36_1         
    cryptography:     2.2.2-py36h14c3975_0 
    cycler:           0.10.0-py36_0        
    dbus:             1.13.2-h714fa37_1    
    expat:            2.2.5-he0dffb1_0     
    fontconfig:       2.12.1-3             
    freetype:         2.5.5-2              
    glib:             2.56.1-h000015b_0    
    gst-plugins-base: 1.14.0-hbbd80ab_1    
    gstreamer:        1.14.0-hb453b48_1    
    icu:              54.1-0               
    idna:             2.6-py36h82fb2a8_1   
    intel-openmp:     2018.0.3-0           
    jpeg:             9b-h024ee3a_2        
    libffi:           3.2.1-hd88cf55_4     
    libgcc:           7.2.0-h69d50b8_2     
    libgcc-ng:        7.2.0-hdf63c60_3     
    libiconv:         1.14-0               
    libpng:           1.6.34-hb9fc6fc_0    
    libstdcxx-ng:     7.2.0-hdf63c60_3     
    libxcb:           1.13-h1bed415_1      
    libxml2:          2.9.4-0              
    matplotlib:       2.0.2-np113py36_0    
    mkl:              2017.0.4-h4c4d0af_0  
    more-itertools:   4.2.0-py36_0         
    numpy:            1.13.1-py36_0        
    openssl:          1.0.2o-h20670df_0    
    pcre:             8.42-h439df22_0      
    pip:              10.0.1-py36_0        
    pluggy:           0.6.0-py36_0         
    py:               1.5.4-py36_0         
    pycparser:        2.18-py36_1          
    pyopenssl:        18.0.0-py36_0        
    pyparsing:        2.2.0-py36_1         
    pyqt:             5.6.0-py36h22d08a2_6 
    pysocks:          1.6.8-py36_0         
    pytest:           3.6.3-py36_0         
    python:           3.6.2-0              
    python-dateutil:  2.7.3-py36_0         
    pytz:             2018.5-py36_0        
    qt:               5.6.2-5              
    readline:         6.2-2                
    requests:         2.18.4-py36he2e5f8d_1
    setuptools:       39.2.0-py36_0        
    sip:              4.18.1-py36hf484d3e_2
    six:              1.11.0-py36_1        
    sqlite:           3.13.0-0             
    tk:               8.5.18-0             
    urllib3:          1.22-py36hbe7ace6_0  
    wheel:            0.31.1-py36_0        
    xz:               5.2.4-h14c3975_4     
    zlib:             1.2.11-ha838bed_2    





Reply 1

Resend
From: Ignacio de la Calle <xmmhelp@sciops.esa.int>
To: pere.munar@uab.cat
Subject: Re: sas 17 installation (PR#83741)
Date: Thu Jul 26 13:06:00 2018
Dear Pere Munar-Adrover,

I have forwarded the issue you are dealing with to the SAS team. I will come
back to you once I have an answer.

Thanks,

Ignacio de la Calle
XMM-Newton SOC

> Submission from: (NULL) (193.147.152.102)
> 
> 
> Dear helpdesk team,
> 
> I am experiencing some problems when installing SAS version 17.0.0: I am
trying
> to install it on a Fedora 27 machine with 64 bits intel processor and 16
Gb
> RAM.
> 
> I downloaded both the RedHat and th Ubuntu binaries (sas_17.0.0-RHEL6.8-64
and
> sas_17.0.0-Ubuntu16.04-64). But with both I end up in the same place: when
> running the installation script it enters what seems an infinite loop (I
let
if
> for hours and it did not finish installing) in which it says the following,
over
> and over again (look at the botton of the message).
> 
> I do not know what can I try.
> 
> Can you give me some advice?
> 
> Thanks a lot!
> 
> Regards,
> 
> Pere
> 
> This is the message that appears over and over:
> 
> 
> 	Downloading Python modules needed for SAS from Conda repositories ...
> 	..................^C/home/pmunar/bin/sas_17.0.0-RHEL6.8-64/xmmsas_20180620_1732/pythonInstaller/miniconda_and_env_installer.sh:
> l.nia 147: kill: (11999) - No such process
> done
> 	!!! Some needed Python pkgs are missing unedr the environment:
sas_17.0.0.
> Exiting !!! 
> 	Ready to install the correct Python environment for SAS ...
> 	(Python env sas_17.0.0 will be removed and re-installed for the correct
one)
> 
> Package plan for package removal in environment
> /home/pmunar/bin/sas_17.0.0-RHEL6.8-64/xmmsas_20180620_1732/miniconda3/envs/sas_17.0.0:
> 
> The following packages will be REMOVED:
> 
>     asn1crypto:       0.24.0-py36_0        
>     astropy:          2.0.1-np113py36_0    
>     atomicwrites:     1.1.5-py36_0         
>     attrs:            18.1.0-py36_0        
>     ca-certificates:  2018.03.07-0         
>     certifi:          2018.4.16-py36_0     
>     cffi:             1.11.5-py36h9745a5d_0
>     chardet:          3.0.4-py36_1         
>     cryptography:     2.2.2-py36h14c3975_0 
>     cycler:           0.10.0-py36_0        
>     dbus:             1.13.2-h714fa37_1    
>     expat:            2.2.5-he0dffb1_0     
>     fontconfig:       2.12.1-3             
>     freetype:         2.5.5-2              
>     glib:             2.56.1-h000015b_0    
>     gst-plugins-base: 1.14.0-hbbd80ab_1    
>     gstreamer:        1.14.0-hb453b48_1    
>     icu:              54.1-0               
>     idna:             2.6-py36h82fb2a8_1   
>     intel-openmp:     2018.0.3-0           
>     jpeg:             9b-h024ee3a_2        
>     libffi:           3.2.1-hd88cf55_4     
>     libgcc:           7.2.0-h69d50b8_2     
>     libgcc-ng:        7.2.0-hdf63c60_3     
>     libiconv:         1.14-0               
>     libpng:           1.6.34-hb9fc6fc_0    
>     libstdcxx-ng:     7.2.0-hdf63c60_3     
>     libxcb:           1.13-h1bed415_1      
>     libxml2:          2.9.4-0              
>     matplotlib:       2.0.2-np113py36_0    
>     mkl:              2017.0.4-h4c4d0af_0  
>     more-itertools:   4.2.0-py36_0         
>     numpy:            1.13.1-py36_0        
>     openssl:          1.0.2o-h20670df_0    
>     pcre:             8.42-h439df22_0      
>     pip:              10.0.1-py36_0        
>     pluggy:           0.6.0-py36_0         
>     py:               1.5.4-py36_0         
>     pycparser:        2.18-py36_1          
>     pyopenssl:        18.0.0-py36_0        
>     pyparsing:        2.2.0-py36_1         
>     pyqt:             5.6.0-py36h22d08a2_6 
>     pysocks:          1.6.8-py36_0         
>     pytest:           3.6.3-py36_0         
>     python:           3.6.2-0              
>     python-dateutil:  2.7.3-py36_0         
>     pytz:             2018.5-py36_0        
>     qt:               5.6.2-5              
>     readline:         6.2-2                
>     requests:         2.18.4-py36he2e5f8d_1
>     setuptools:       39.2.0-py36_0        
>     sip:              4.18.1-py36hf484d3e_2
>     six:              1.11.0-py36_1        
>     sqlite:           3.13.0-0             
>     tk:               8.5.18-0             
>     urllib3:          1.22-py36hbe7ace6_0  
>     wheel:            0.31.1-py36_0        
>     xz:               5.2.4-h14c3975_4     
>     zlib:             1.2.11-ha838bed_2    
> 
> 
> 
> 
> 


Reply 2

Resend
From: Ignacio de la Calle <xmmhelp@sciops.esa.int>
To: pere.munar@uab.cat
Subject: Re: sas 17 installation (PR#83741)
Date: Mon Jul 30 15:05:44 2018
Dear Pere Munar-Adrover,

Sorry for the late reply.

We need a couple of things. The first one is that you start the installation
from scratch and send us the full log. We need to see what you get before 
the error message that you report.

./install.sh >& install_sas.log

Also, can you send us the output of the command env ? We need to see what
environment variables you have.

Regards,

Ignacio de la Calle
XMM-Newton SOC

> Full_Name: Pere Munar-Adrover
> Submission from: (NULL) (193.147.152.102)
> 
> 
> Dear helpdesk team,
> 
> I am experiencing some problems when installing SAS version 17.0.0: I am
trying
> to install it on a Fedora 27 machine with 64 bits intel processor and 16
Gb
> RAM.
> 
> I downloaded both the RedHat and th Ubuntu binaries (sas_17.0.0-RHEL6.8-64
and
> sas_17.0.0-Ubuntu16.04-64). But with both I end up in the same place: when
> running the installation script it enters what seems an infinite loop (I
let
if
> for hours and it did not finish installing) in which it says the following,
over
> and over again (look at the botton of the message).
> 
> I do not know what can I try.
> 
> Can you give me some advice?
> 
> Thanks a lot!
> 
> Regards,
> 
> Pere
> 
> This is the message that appears over and over:
> 
> 
> 	Downloading Python modules needed for SAS from Conda repositories ...
> 	..................^C/home/pmunar/bin/sas_17.0.0-RHEL6.8-64/xmmsas_20180620_1732/pythonInstaller/miniconda_and_env_installer.sh:
> l.nia 147: kill: (11999) - No such process
> done
> 	!!! Some needed Python pkgs are missing unedr the environment:
sas_17.0.0.
> Exiting !!! 
> 	Ready to install the correct Python environment for SAS ...
> 	(Python env sas_17.0.0 will be removed and re-installed for the correct
one)
> 
> Package plan for package removal in environment
> /home/pmunar/bin/sas_17.0.0-RHEL6.8-64/xmmsas_20180620_1732/miniconda3/envs/sas_17.0.0:
> 
> The following packages will be REMOVED:
> 
>     asn1crypto:       0.24.0-py36_0        
>     astropy:          2.0.1-np113py36_0    
>     atomicwrites:     1.1.5-py36_0         
>     attrs:            18.1.0-py36_0        
>     ca-certificates:  2018.03.07-0         
>     certifi:          2018.4.16-py36_0     
>     cffi:             1.11.5-py36h9745a5d_0
>     chardet:          3.0.4-py36_1         
>     cryptography:     2.2.2-py36h14c3975_0 
>     cycler:           0.10.0-py36_0        
>     dbus:             1.13.2-h714fa37_1    
>     expat:            2.2.5-he0dffb1_0     
>     fontconfig:       2.12.1-3             
>     freetype:         2.5.5-2              
>     glib:             2.56.1-h000015b_0    
>     gst-plugins-base: 1.14.0-hbbd80ab_1    
>     gstreamer:        1.14.0-hb453b48_1    
>     icu:              54.1-0               
>     idna:             2.6-py36h82fb2a8_1   
>     intel-openmp:     2018.0.3-0           
>     jpeg:             9b-h024ee3a_2        
>     libffi:           3.2.1-hd88cf55_4     
>     libgcc:           7.2.0-h69d50b8_2     
>     libgcc-ng:        7.2.0-hdf63c60_3     
>     libiconv:         1.14-0               
>     libpng:           1.6.34-hb9fc6fc_0    
>     libstdcxx-ng:     7.2.0-hdf63c60_3     
>     libxcb:           1.13-h1bed415_1      
>     libxml2:          2.9.4-0              
>     matplotlib:       2.0.2-np113py36_0    
>     mkl:              2017.0.4-h4c4d0af_0  
>     more-itertools:   4.2.0-py36_0         
>     numpy:            1.13.1-py36_0        
>     openssl:          1.0.2o-h20670df_0    
>     pcre:             8.42-h439df22_0      
>     pip:              10.0.1-py36_0        
>     pluggy:           0.6.0-py36_0         
>     py:               1.5.4-py36_0         
>     pycparser:        2.18-py36_1          
>     pyopenssl:        18.0.0-py36_0        
>     pyparsing:        2.2.0-py36_1         
>     pyqt:             5.6.0-py36h22d08a2_6 
>     pysocks:          1.6.8-py36_0         
>     pytest:           3.6.3-py36_0         
>     python:           3.6.2-0              
>     python-dateutil:  2.7.3-py36_0         
>     pytz:             2018.5-py36_0        
>     qt:               5.6.2-5              
>     readline:         6.2-2                
>     requests:         2.18.4-py36he2e5f8d_1
>     setuptools:       39.2.0-py36_0        
>     sip:              4.18.1-py36hf484d3e_2
>     six:              1.11.0-py36_1        
>     sqlite:           3.13.0-0             
>     tk:               8.5.18-0             
>     urllib3:          1.22-py36hbe7ace6_0  
>     wheel:            0.31.1-py36_0        
>     xz:      

Message of length 5115 truncated

Up to top level
AO15   AO16   AO17   AO18   Backgrounds   Calibration   Conference   Data   Docs   EPICMOS   EPICpn   Feedback   Gallery   Misc   OM   Pending   PhD_Theses   Publications   RGS   RadMonitor   SAS_Hardware   SAS_WS   SASv16.0   SASv16.0_Installation   SASv16.1   SASv16.1_Installation   SASv17.0   SASv17.0_Installation   SciSim   Simulators_other   Suggestions   Trash   Visibility   XMM-bouncing   XMM-news   XRPS   XSA   esas   incoming  

Logged in as guest


Please make your (short) question the subject of your request!


Web interface using JitterBug ... back to the XMM home page