Up to top level
AO15   AO16   AO17   AO18   Backgrounds   Calibration   Conference   Data   Docs   EPICMOS   EPICpn   Feedback   Gallery   Misc   OM   Pending   PhD_Theses   Publications   RGS   RadMonitor   SAS_Hardware   SAS_WS   SASv16.0   SASv16.0_Installation   SASv16.1   SASv16.1_Installation   SASv17.0   SASv17.0_Installation   SciSim   Simulators_other   Suggestions   Trash   Visibility   XMM-bouncing   XMM-news   XRPS   XSA   esas   incoming  

Logged in as guest

Viewing SASv16.0_Installation/81401
Full headers

From: kafrank@psu.edu
Subject: epchain command not found
Compose reply
Download message
Move To:
5 replies: 1 2 3 4 5
4 followups: 1 2 3 4

Private message: yes  no

Notes:

Notification:


Date: Thu, 13 Apr 2017 14:13:37 GMT
From: kafrank@psu.edu
To: xmmhelp@sciops.esa.int
CC: kafrank@psu.edu
Subject: epchain command not found
Full_Name: Kari Frank
Submission from: (NULL) (128.118.147.37)


I am trying to reprocess some observations, and I can't get epchain to work.
Whenever I try to call it, I get the error "epchain: Command not found".
However, all other commands, including emchain, seem to work fine. "which
epchain" returns the correct the path:
/<path>/xmmsas_20170112_1337/bin/epchain.

The same problem has occurred on two different observations so far, 0085200301
and 0085200401. I have tried re-installing SAS and heasoft, but it did not help.
I'm at a loss as to what to try next. Any ideas what could be wrong?

I am running the latest SAS version from January 2017, with the 16.0 patches
applied. The OS is Ubuntu 16.04.2 LTS

Thanks,
Kari


Reply 1

Resend
From: Nora Loiseau <xmmhelp@sciops.esa.int>
To: kafrank@psu.edu
Subject: Re: epchain command not found (PR#81401)
Date: Fri Apr 14 09:25:30 2017
Dear Kari,

Please send us the log of your complete SAS session BOSITY=5 for us
to try to reproduce your problem.

Best regards,

Nora

> 
> I am trying to reprocess some observations, and I can't get epchain to
work.
> Whenever I try to call it, I get the error "epchain: Command not found".
> However, all other commands, including emchain, seem to work fine. "which
> epchain" returns the correct the path:
> /<path>/xmmsas_20170112_1337/bin/epchain.
> 
> The same problem has occurred on two different observations so far,
0085200301
> and 0085200401. I have tried re-installing SAS and heasoft, but it did not
help.
> I'm at a loss as to what to try next. Any ideas what could be wrong?
> 
> I am running the latest SAS version from January 2017, with the 16.0
patches
> applied. The OS is Ubuntu 16.04.2 LTS
> 
> Thanks,
> Kari
> 
> 


Followup 1

Compose reply
Download message
From: Kari Frank <kafrank@psu.edu>
Date: Fri, 14 Apr 2017 10:05:50 -0400
Subject: Re: epchain command not found (PR#81401)
To: Nora Loiseau <xmmhelp@sciops.esa.int>
--f403045f20fa39272b054d20f279
Content-Type: multipart/alternative; boundary=f403045f20fa392726054d20f277

--f403045f20fa392726054d20f277
Content-Type: text/plain; charset=UTF-8

Hi Nora,

The session log is pasted below. The log files cifbuild.log, odfingest.log,
and emchain1.log  are attached (assuming attachments work) in case you want
to check them, but all returned no errors and seemed to work as expected.
Only epchain is being problematic.

Thanks,
Kari

#### Initialize session

kaf33@rice:xmc_repro_sas16$ source $SAS_DIR/setsas.csh

sasversion:- Executing (routine): sasversion  -w 1 -V 4
sasversion:- sasversion (sasversion-1.2)  [xmmsas_20170112_1337-16.0.0]
started:  2017-04-14T13:55:47.000
sasversion:- XMM-Newton SAS release and build information:

SAS release: xmmsas_20170112_1337-16.0.0
Compiled on: Thu Jan 12 15:08:46 CET 2017
Compiled by: sasbuild@sasbld12
Platform   : Ubuntu16.04 64

SAS-related environment variables that are set:

SAS_DIR = /data/drive1/local/xmmsas_20170112_1337
SAS_PATH = /data/drive1/local/xmmsas_20170112_1337
SAS_CCFPATH = /data/drive1/local/ccf

sasversion:- sasversion (sasversion-1.2)  [xmmsas_20170112_1337-16.0.0]
ended:    2017-04-14T13:55:47.000

Do not forget to define SAS_CCF and SAS_ODF

kaf33@rice:xmc_repro_sas16$ setenv SAS_ODF $PWD/../odf

#### cifbuild and odfingest

kaf33@rice:xmc_repro_sas16$ cifbuild withccfpath=no analysisdate=now
category=XMMCCF fullpath=yes >&! cifbuild.log

kaf33@rice:xmc_repro_sas16$ setenv SAS_CCF $PWD/ccf.cif
kaf33@rice:xmc_repro_sas16$ odfingest odfdir=$SAS_ODF outdir=$PWD >&!
odfingest.log
kaf33@rice:xmc_repro_sas16$ set sumfile='*SUM.SAS'
kaf33@rice:xmc_repro_sas16$ setenv SAS_ODF $PWD/$sumfile
kaf33@rice:xmc_repro_sas16$
kaf33@rice:xmc_repro_sas16$ echo "SAS_ODF = $SAS_ODF"
SAS_ODF =
/data/nasdrive/main/kaf33/spies/xmm_observations/3C397/obsid_0085200301/xmc_repro_sas16/0705_0085200301_SCX00000SUM.SAS
kaf33@rice:xmc_repro_sas16$ echo "SAS_CCF = $SAS_CCF"
SAS_CCF =
/data/nasdrive/main/kaf33/spies/xmm_observations/3C397/obsid_0085200301/xmc_repro_sas16/ccf.cif

kaf33@rice:xmc_repro_sas16$ sasversion
sasversion:- Executing (routine): sasversion  -w 1 -V 4
sasversion:- sasversion (sasversion-1.2)  [xmmsas_20170112_1337-16.0.0]
started:  2017-04-14T13:49:19.000
sasversion:- XMM-Newton SAS release and build information:

SAS release: xmmsas_20170112_1337-16.0.0
Compiled on: Thu Jan 12 15:08:46 CET 2017
Compiled by: sasbuild@sasbld12
Platform   : Ubuntu16.04 64

SAS-related environment variables that are set:

SAS_DIR = /data/drive1/local/xmmsas_20170112_1337
SAS_PATH = /data/drive1/local/xmmsas_20170112_1337
SAS_CCFPATH = /data/drive1/local/ccf
SAS_CCF = ccf.cif
SAS_ODF = 0705_0085200301_SCX00000SUM.SAS

sasversion:- sasversion (sasversion-1.2)  [xmmsas_20170112_1337-16.0.0]
ended:    2017-04-14T13:49:19.000

#### Try epchain

kaf33@rice:xmc_repro_sas16$ which epchain
/data/drive1/local/xmmsas_20170112_1337/bin/epchain
kaf33@rice:xmc_repro_sas16$ epchain
epchain: Command not found.

#### Try emchain

kaf33@rice:xmc_repro_sas16$ set M1exp=S001
kaf33@rice:xmc_repro_sas16$ emchain applyflaregti=yes exposures=$M1exp >&
emchain1.log


On Fri, Apr 14, 2017 at 5:25 AM, Nora Loiseau <xmmhelp@sciops.esa.int>
wrote:

> Dear Kari,
>
> Please send us the log of your complete SAS session BOSITY=5 for us
> to try to reproduce your problem.
>
> Best regards,
>
> Nora
>
> >
> > I am trying to reprocess some observations, and I can't get epchain to
> work.
> > Whenever I try to call it, I get the error "epchain: Command not
found".
> > However, all other commands, including emchain, seem to work fine.
"which
> > epchain" returns the correct the path:
> > /<path>/xmmsas_20170112_1337/bin/epchain.
> >
> > The same problem has occurred on two different observations so far,
> 0085200301
> > and 0085200401. I have tried re-installing SAS and heasoft, but it did
> not
> help.
> > I'm at a loss as to what to try next. Any ideas what could be wrong?
> >
> > I am running the latest SAS version from January 2017, with the 16.0
> patches
> > applied. The OS is Ubuntu 16.04.2 LTS
> >
> > Thanks,
> > Kari
> >
> >
>
> This message and any attachments are intended for the use of the addressee
> or addressees only.
> The unauthorised disclosure, use, dissemination or copying (either in
> whole or in part) of its
> content is not permitted.
> If you received this message in error, please notify the sender and delete
> it from your system.
> Emails can be altered and their integrity cannot be guaranteed by the
> sender.
>
> Please consider the environment before printing this email.
>
>
>

--f403045f20fa392726054d20f277
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr">Hi Nora,<div>&l

Message of length 370664 truncated


Reply 2

Resend
From: Nora Loiseau <xmmhelp@sciops.esa.int>
To: kafrank@psu.edu
Subject: Re: epchain command not found (PR#81401)
Date: Mon Apr 17 11:44:27 2017
Dear Kari,

I am consulting a SAS expert about this strange situation.
I will come back to you as soon as I have his reply.

Best regards,

Nora

> 
> I am trying to reprocess some observations, and I can't get epchain to
work.
> Whenever I try to call it, I get the error "epchain: Command not found".
> However, all other commands, including emchain, seem to work fine. "which
> epchain" returns the correct the path:
> /<path>/xmmsas_20170112_1337/bin/epchain.
> 
> The same problem has occurred on two different observations so far,
0085200301
> and 0085200401. I have tried re-installing SAS and heasoft, but it did not
help.
> I'm at a loss as to what to try next. Any ideas what could be wrong?
> 
> I am running the latest SAS version from January 2017, with the 16.0
patches
> applied. The OS is Ubuntu 16.04.2 LTS
> 
> Thanks,
> Kari
> 
> ----
Dr. Nora Loiseau
XMM-Newton User Support Group


Reply 3

Resend
From: Nora Loiseau <xmmhelp@sciops.esa.int>
To: kafrank@psu.edu
Subject: Re: epchain command not found (PR#81401)
Date: Mon Apr 17 13:31:49 2017
Dear Kari,

A problem must have happened by the SAS installation. Please send us the answer
to the command .which perl. and the headlines of both epchain and emchain in
your installation, from a window where you have initialised SAS (ie. after
'source $SAS_DIR/setsas.csh.)

Regards,

Nora
----
Dr. Nora Loiseau
XMM-Newton User Support Group


Followup 2

Compose reply
Download message
From: Kari Frank <kafrank@psu.edu>
Date: Mon, 17 Apr 2017 10:03:11 -0400
Subject: Re: epchain command not found (PR#81401)
To: Nora Loiseau <xmmhelp@sciops.esa.int>
--001a114b82583a4794054d5d4258
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Hi Nora,

'which perl' returns '/usr/bin/perl'
'perl --version' returns version 5.22.1

What do you mean by the 'headlines' of em/epchain?

It might be of interest that I have tried installing xmmsas twice, with the
same result both times (the weird epchain command not found error). The
first time, I installed both heasoft-6.20 and xmmsas using the default perl
installation. After the epchain problem surfaced, I noticed that the docs
say perl 5.22.2 is required, but my default version is 5.22.1. So I
installed perlbrew as recommended and then perl 5.22.2. I set this version
of perl (setenv
PERL /data/drive1/local/perlbrew/perls/perl-5.22.2/bin/perl5.22.2)
before installing heasoft-6.21 (which had just been released), and then
installed xmmsas with 'setenv
SAS_PERL /data/drive1/local/perlbrew/perls/perl-5.22.2/bin/perl5.22.2'. In
either case, sas behaved exactly the same - everything seems to work except
epchain.

Is it possible that even though it was installed with the newer version of
perl, sas is trying to use the default (5.22.1) version at run time, and
that's why I get the same errors? If so, how do I set the correct version
of perl for a particular session/window? I've tried figuring out how to do
that, but the perlbrew documentation is a little sparse.

Thanks,
Kari



On Mon, Apr 17, 2017 at 9:31 AM, Nora Loiseau <xmmhelp@sciops.esa.int>
wrote:

> Dear Kari,
>
> A problem must have happened by the SAS installation. Please send us the
> answer
> to the command =E2=80=9Cwhich perl=E2=80=9D and the headlines of both epc=
hain and emchain
> in
> your installation, from a window where you have initialised SAS (ie. afte=
r
> 'source $SAS_DIR/setsas.csh=E2=80=99)
>
> Regards,
>
> Nora
> ----
> Dr. Nora Loiseau
> XMM-Newton User Support Group
>
> This message and any attachments are intended for the use of the addresse=
e
> or addressees only.
> The unauthorised disclosure, use, dissemination or copying (either in
> whole or in part) of its
> content is not permitted.
> If you received this message in error, please notify the sender and delet=
e
> it from your system.
> Emails can be altered and their integrity cannot be guaranteed by the
> sender.
>
> Please consider the environment before printing this email.
>
>
>

--001a114b82583a4794054d5d4258
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr">Hi
Nora,<div><br></div><div>&#39;which perl&#39;
returns &=
#39;/usr/bin/perl&#39;</div><div>&#39;perl
--version&#39; returns version 5=
.22.1</div><div><br></div><div>What do you mean by
the &#39;headlines&#39; =
of em/epchain?</div><div><br></div><div><font
face=3D"arial, helvetica, san=
s-serif">It might be of interest that I have tried installing xmmsas twice,=
 with the same result both times (the weird epchain command not found error=
). The first time, I installed both heasoft-6.20 and xmmsas using the defau=
lt perl installation. After the epchain problem surfaced, I noticed that th=
e docs say perl 5.22.2 is required, but my default version is 5.22.1. So I =
installed perlbrew as recommended and then perl 5.22.2. I set this version =
of perl (setenv PERL=C2=A0/data/drive1/local/perlbrew/perls/perl-5.22.2/bin=
/perl5.22.2) before=C2=A0installing heasoft-6.21 (which had just been relea=
sed), and then installed xmmsas with &#39;setenv SAS_PERL=C2=A0/data/drive1=
/local/perlbrew/perls/perl-5.22.2/bin/perl5.22.2&#39;. In either case, sas =
behaved exactly the same - everything seems to work except
epchain.</font><=
/div><div><font face=3D"arial, helvetica,
sans-serif"><br></font></div><div=
><font face=3D"arial, helvetica, sans-serif">Is it possible that even
thoug=
h it was installed with the newer version of perl, sas is trying to use the=
 default (5.22.1) version at run time, and that&#39;s why I get the same er=
rors? If so, how do I set the correct version of perl for a particular sess=
ion/window? I&#39;ve tried figuring out how to do that, but the perlbrew do=
cumentation is a little sparse.</font></div><div><font
face=3D"arial, helve=
tica, sans-serif"><br></font></div><div><font
face=3D"arial, helvetica, san=
s-serif">Thanks,</font></div><div><font face=3D"arial,
helvetica, sans-seri=
f">Kari</font></div><div><span
style=3D"font-family:&quot;courier new&quot;=
,courier,monospace;font-size:14px"><br></span></div><div><br></div></div><d=
iv class=3D"gmail_extra"><br><div c

Message of length 6595 truncated


Reply 4

Resend
From: Nora Loiseau <xmmhelp@sciops.esa.int>
To: kafrank@psu.edu
Subject: Re: epchain command not found (PR#81401)
Date: Mon Apr 17 17:44:19 2017
Dear Kari,

The headline (first line in the perl scripts, ie. "epchain" and "emchain") gets
modified by the SAS installing procedure (when you run the .install.sh.
procedure) to cope with your local Perl environment. .epchain. and .emchain. are
both residing under $SAS_DIR/bin. We suspect that something must have gone wrong
during the installation, to check this we need to see those headlines. 

Regards,

Nora
----
Dr. Nora Loiseau
XMM-Newton User Support Group


Followup 3

Compose reply
Download message
From: Kari Frank <kafrank@psu.edu>
Date: Mon, 17 Apr 2017 13:54:49 -0400
Subject: Re: epchain command not found (PR#81401)
To: Nora Loiseau <xmmhelp@sciops.esa.int>
--001a114b801097574c054d607ecf
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Hi Nora,

That makes sense. The headlines are pasted below for the installation which
had the perl version set to the perlbrew 5.22.2 version.

First line in epchain:
#!/usr/local/bin/perl -w

First line in emchain:
#! /data/drive1/local/perlbrew/perls/perl-5.22.2/bin/perl5.22.2 -w

The previous installation of xmmsas, which used the system default perl:

ephain:
#!/usr/local/bin/perl -w

and emchain:
#! /usr/bin/perl -w

It does look like (in both cases) epchain is using a different perl than
emchain for some reason.

~Kari


On Mon, Apr 17, 2017 at 1:44 PM, Nora Loiseau <xmmhelp@sciops.esa.int>
wrote:

> Dear Kari,
>
> The headline (first line in the perl scripts, ie. "epchain" and "emchain"=
)
> gets
> modified by the SAS installing procedure (when you run the =E2=80=9Cinsta=
ll.sh=E2=80=9D
> procedure) to cope with your local Perl environment. =E2=80=9Cepchain=E2=
=80=9D and
> =E2=80=9Cemchain=E2=80=9D are
> both residing under $SAS_DIR/bin. We suspect that something must have gon=
e
> wrong
> during the installation, to check this we need to see those headlines.
>
> Regards,
>
> Nora
> ----
> Dr. Nora Loiseau
> XMM-Newton User Support Group
>
> This message and any attachments are intended for the use of the addresse=
e
> or addressees only.
> The unauthorised disclosure, use, dissemination or copying (either in
> whole or in part) of its
> content is not permitted.
> If you received this message in error, please notify the sender and delet=
e
> it from your system.
> Emails can be altered and their integrity cannot be guaranteed by the
> sender.
>
> Please consider the environment before printing this email.
>
>
>

--001a114b801097574c054d607ecf
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr"><div>Hi
Nora,=C2=A0</div><div><br></div><div>That makes
se=
nse. The headlines are pasted below for the installation which had the perl=
 version set to the perlbrew 5.22.2
version.</div><div><br></div><div>First=
 line in epchain:</div><div>#!/usr/local/bin/perl
-w</div><div><br></div><d=
iv>First line in emchain:</div><div>#!
/data/drive1/local/perlbrew/perls/pe=
rl-5.22.2/bin/perl5.22.2
-w<br></div><div><br></div><div>The previous
insta=
llation of xmmsas, which used the system default
perl:</div><div><br></div>=
<div>ephain:</div><div><div>#!/usr/local/bin/perl
-w</div></div><div><br></=
div><div>and emchain:</div><div>#! /usr/bin/perl
-w<br></div><div><br></div=
><div>It does look like (in both cases) epchain is using a different
perl t=
han emchain for some
reason.</div><div><br></div><div>~Kari</div><div><br><=
/div><div class=3D"gmail_extra"><br><div
class=3D"gmail_quote">On Mon, Apr =
17, 2017 at 1:44 PM, Nora Loiseau <span dir=3D"ltr">&lt;<a
href=3D"mailto:x=
mmhelp@sciops.esa.int"
target=3D"_blank">xmmhelp@sciops.esa.int</a>&gt;</sp=
an> wrote:<br><blockquote class=3D"gmail_quote" style=3D"margin:0px
0px 0px=
 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Dear
Kari,<=
br>
<br>
The headline (first line in the perl scripts, ie. &quot;epchain&quot;
and &=
quot;emchain&quot;) gets<br>
modified by the SAS installing procedure (when you run the =E2=80=9Cinstall=
.sh=E2=80=9D<br>
procedure) to cope with your local Perl environment. =E2=80=9Cepchain=E2=80=
=9D and =E2=80=9Cemchain=E2=80=9D are<br>
both residing under $SAS_DIR/bin. We suspect that something must have gone =
wrong<br>
during the installation, to check this we need to see those headlines.<br>
<div class=3D"gmail-HOEnZb"><div class=3D"gmail-h5"><br>
Regards,<br>
<br>
Nora<br>
----<br>
Dr. Nora Loiseau<br>
XMM-Newton User Support Group<br>
<br>
This message and any attachments are intended for the use of the addressee =
or addressees only.<br>
The unauthorised disclosure, use, dissemination or copying (either in whole=
 or in part) of its<br>
content is not permitted.<br>
If you received this message in error, please notify the sender and delete =
it from your system.<br>
Emails can be altered and their integrity cannot be guaranteed by the sende=
r.<br>
<br>
Please consider the environment before printing this email.<br>
<br>
<br>
</div></div></blockquote></div><br>

Message of length 5061 truncated


Reply 5

Resend
From: Nora Loiseau <xmmhelp@sciops.esa.int>
To: kafrank@psu.edu
Subject: Re: epchain command not found (PR#81401)
Date: Wed Apr 19 18:53:19 2017
Hi Kari,

The SAS developers found out that the last SAS 16 patch includes epchain-8.76.1,
which is installed after having performed the general installation. Then epchain
is the new one with a she-bang not changed.
Solution: Please change by hand the first line of the script epchain, replacing
it by the same first line of the script emchain.
A watchout will be included in the SAS web pages.

Thanks for pointing to this issue!,

Nora



> --001a114b801097574c054d607ecf
> Content-Type: text/plain; charset=UTF-8
> Content-Transfer-Encoding: quoted-printable
> 
> Hi Nora,
> 
> That makes sense. The headlines are pasted below for the installation
which
> had the perl version set to the perlbrew 5.22.2 version.
> 
> First line in epchain:
> #!/usr/local/bin/perl -w
> 
> First line in emchain:
> #! /data/drive1/local/perlbrew/perls/perl-5.22.2/bin/perl5.22.2 -w
> 
> The previous installation of xmmsas, which used the system default perl:
> 
> ephain:
> #!/usr/local/bin/perl -w
> 
> and emchain:
> #! /usr/bin/perl -w
> 
> It does look like (in both cases) epchain is using a different perl than
> emchain for some reason.
> 
> ~Kari
> 
> 
> On Mon, Apr 17, 2017 at 1:44 PM, Nora Loiseau
<xmmhelp@sciops.esa.int>
> wrote:
> 
>> Dear Kari,
>>
>> The headline (first line in the perl scripts, ie. "epchain" and
"emchain"=
> )
>> gets
>> modified by the SAS installing procedure (when you run the
=E2=80=9Cinsta=
> ll.sh=E2=80=9D
>> procedure) to cope with your local Perl environment.
=E2=80=9Cepchain=E2=
> =80=9D and
>> =E2=80=9Cemchain=E2=80=9D are
>> both residing under $SAS_DIR/bin. We suspect that something must have
gon=
> e
>> wrong
>> during the installation, to check this we need to see those headlines.
>>
>> Regards,
>>
>> Nora
>> ----
>> Dr. Nora Loiseau
>> XMM-Newton User Support Group
>>
----
Dr. Nora Loiseau
XMM-Newton User Support Group


Followup 4

Compose reply
Download message
From: Kari Frank <kafrank@psu.edu>
Date: Wed, 19 Apr 2017 16:11:46 -0400
Subject: Re: epchain command not found (PR#81401)
To: Nora Loiseau <xmmhelp@sciops.esa.int>
--001a114426440ba33f054d8aa4f5
Content-Type: text/plain; charset=UTF-8

Hi Nora,

That seems to do the trick; epchain is working normally now.

Glad it was an easy fix!

Thanks,
Kari

On Wed, Apr 19, 2017 at 2:53 PM, Nora Loiseau <xmmhelp@sciops.esa.int>
wrote:

> Hi Kari,
>
> The SAS developers found out that the last SAS 16 patch includes
> epchain-8.76.1,
> which is installed after having performed the general installation. Then
> epchain
> is the new one with a she-bang not changed.
> Solution: Please change by hand the first line of the script epchain,
> replacing
> it by the same first line of the script emchain.
> A watchout will be included in the SAS web pages.
>
> Thanks for pointing to this issue!,
>
> Nora
>
>
>
> > --001a114b801097574c054d607ecf
> > Content-Type: text/plain; charset=UTF-8
> > Content-Transfer-Encoding: quoted-printable
> >
> > Hi Nora,
> >
> > That makes sense. The headlines are pasted below for the installation
> which
> > had the perl version set to the perlbrew 5.22.2 version.
> >
> > First line in epchain:
> > #!/usr/local/bin/perl -w
> >
> > First line in emchain:
> > #! /data/drive1/local/perlbrew/perls/perl-5.22.2/bin/perl5.22.2 -w
> >
> > The previous installation of xmmsas, which used the system default
perl:
> >
> > ephain:
> > #!/usr/local/bin/perl -w
> >
> > and emchain:
> > #! /usr/bin/perl -w
> >
> > It does look like (in both cases) epchain is using a different perl
than
> > emchain for some reason.
> >
> > ~Kari
> >
> >
> > On Mon, Apr 17, 2017 at 1:44 PM, Nora Loiseau
<xmmhelp@sciops.esa.int>
> > wrote:
> >
> >> Dear Kari,
> >>
> >> The headline (first line in the perl scripts, ie. "epchain" and
> "emchain"=
> > )
> >> gets
> >> modified by the SAS installing procedure (when you run the
> =E2=80=9Cinsta=
> > ll.sh=E2=80=9D
> >> procedure) to cope with your local Perl environment.
> =E2=80=9Cepchain=E2=
> > =80=9D and
> >> =E2=80=9Cemchain=E2=80=9D are
> >> both residing under $SAS_DIR/bin. We suspect that something must
have
> gon=
> > e
> >> wrong
> >> during the installation, to check this we need to see those
headlines.
> >>
> >> Regards,
> >>
> >> Nora
> >> ----
> >> Dr. Nora Loiseau
> >> XMM-Newton User Support Group
> >>
> ----
> Dr. Nora Loiseau
> XMM-Newton User Support Group
>
> This message and any attachments are intended for the use of the addressee
> or addressees only.
> The unauthorised disclosure, use, dissemination or copying (either in
> whole or in part) of its
> content is not permitted.
> If you received this message in error, please notify the sender and delete
> it from your system.
> Emails can be altered and their integrity cannot be guaranteed by the
> sender.
>
> Please consider the environment before printing this email.
>
>
>

--001a114426440ba33f054d8aa4f5
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr">Hi Nora,<div><br></div><div>That
seems to do the trick; ep=
chain is working normally
now.</div><div><br></div><div>Glad it was an easy=
 fix!</div><div><br></div><div>Thanks,<br>Kari</div></div><div
class=3D"gma=
il_extra"><br><div class=3D"gmail_quote">On Wed, Apr 19, 2017 at
2:53 PM, N=
ora Loiseau <span dir=3D"ltr">&lt;<a
href=3D"mailto:xmmhelp@sciops.esa.int"=
 target=3D"_blank">xmmhelp@sciops.esa.int</a>&gt;</span>
wrote:<br><blockqu=
ote class=3D"gmail_quote" style=3D"margin:0 0 0 .8ex;border-left:1px #ccc s=
olid;padding-left:1ex">Hi Kari,<br>
<br>
The SAS developers found out that the last SAS 16 patch includes epchain-8.=
76.1,<br>
which is installed after having performed the general installation. Then ep=
chain<br>
is the new one with a she-bang not changed.<br>
Solution: Please change by hand the first line of the script epchain, repla=
cing<br>
it by the same first line of the script emchain.<br>
A watchout will be included in the SAS web pages.<br>
<br>
Thanks for pointing to this issue!,<br>
<br>
Nora<br>
<br>
<br>
<br>
&gt; --001a114b801097574c054d607ecf<br>
&gt; Content-Type: text/plain; charset=3DUTF-8<br>
&gt; Content-Transfer-Encoding: quoted-printable<br>
<span class=3D"">&gt;<br>
&gt; Hi Nora,<br>
&gt;<br>
&gt; That makes sense. Th

Message of length 8153 truncated

Up to top level
AO15   AO16   AO17   AO18   Backgrounds   Calibration   Conference   Data   Docs   EPICMOS   EPICpn   Feedback   Gallery   Misc   OM   Pending   PhD_Theses   Publications   RGS   RadMonitor   SAS_Hardware   SAS_WS   SASv16.0   SASv16.0_Installation   SASv16.1   SASv16.1_Installation   SASv17.0   SASv17.0_Installation   SciSim   Simulators_other   Suggestions   Trash   Visibility   XMM-bouncing   XMM-news   XRPS   XSA   esas   incoming  

Logged in as guest


Please make your (short) question the subject of your request!


Web interface using JitterBug ... back to the XMM home page