Up to top level
AO15   AO16   AO17   AO18   AO19   Backgrounds   Calibration   Conference   Data   Docs   EPICMOS   EPICpn   Feedback   Gallery   Misc   OM   Pending   PhD_Theses   Publications   RGS   RadMonitor   SAS_Hardware   SAS_WS   SASv16.0   SASv16.0_Installation   SASv16.1   SASv16.1_Installation   SASv17.0   SASv17.0_Installation   SASv18.0   SASv18.0_Installation   SciSim   Simulators_other   Suggestions   Trash   Visibility   XMM-bouncing   XMM-news   XRPS   XSA   esas   incoming  

Logged in as guest

Viewing SASv16.0/82503
Full headers

From: luojiaweil@gmail.com
Subject: Fortran runtime error in embadpixfind
Compose reply
Download message
Move To:
1 replies: 1
0 followups:

Private message: yes  no

Notes:

Notification:


Date: Mon, 23 Oct 2017 07:50:17 GMT
From: luojiaweil@gmail.com
To: xmmhelp@sciops.esa.int
CC: luojiaweil@gmail.com
Subject: Fortran runtime error in embadpixfind
Full_Name: Jiawei Luo
Submission from: (NULL) (159.226.171.34)


I am using SAS 16.1.0 on REHL6.8 with perl 5.22.2. I downloaded the ODF data of
ObsID 0206350101 from XSA and tried to process it.

I used the standard procedure of cifbuild -- odfingest -- emchain to get MOS
eventlist. While this procedure worked well for other observations, the emchain
command, which calls embadpixfind in its workflow, returned a Fortran runtime
error: "At line 1721 of file embadpixfind_mod.f90 Fortran runtime error: End of
record"

I have tried to process this data on two different machines and got the same
error, so I believe this error is due to data corruption, or a bug in
embadpixfind and should be easily reproduced.


Reply 1

Resend
From: Lucia Ballo <xmmhelp@sciops.esa.int>
To: luojiaweil@gmail.com
Subject: Re: Fortran runtime error in embadpixfind (PR#82503)
Date: Wed Oct 25 10:47:33 2017
Dear Jiawei Luo,

The issue has been reported to our SAS team, many thanks for spotting it.

In the meantime, please note that the net result of the error is that the bad
pixels identification in CCD#6 in MOS2 is missing. Therefore, if the data from
this CCD#6 are not relevant for your scientific analysis, you can run emchain
without specific parameters for MOS1 and ignore CCD#6 in the processing of
MOS2:

  emchain instruments="M1"
  emchain ccds="1 2 3 4 5 7" instruments="M2"

Excluding the CCD#6, the emchain for MOS2 runs properly to the end.


If instead you are interested in the data from CCD#6, you can run emchain for
MOS2 with a different bad pixel finding algorithm:

  emchain instruments="M1"
  emchain badpixfindalgo=EP instruments="M2"

Please be aware that with the 'badpixfindalgo=EP' option the hot column in MOS1
CCD#1 is not correctly removed.


We hope that this workaround will be helpful; otherwise please do not hesitate
to contact us again.


Kind regards
Lucia
--
   Dr Lucia Ballo 
   XMM-Newton Science Operations Centre
   Community Support and Scientific Planning Team

Up to top level
AO15   AO16   AO17   AO18   AO19   Backgrounds   Calibration   Conference   Data   Docs   EPICMOS   EPICpn   Feedback   Gallery   Misc   OM   Pending   PhD_Theses   Publications   RGS   RadMonitor   SAS_Hardware   SAS_WS   SASv16.0   SASv16.0_Installation   SASv16.1   SASv16.1_Installation   SASv17.0   SASv17.0_Installation   SASv18.0   SASv18.0_Installation   SciSim   Simulators_other   Suggestions   Trash   Visibility   XMM-bouncing   XMM-news   XRPS   XSA   esas   incoming  

Logged in as guest


Please make your (short) question the subject of your request!


Web interface using JitterBug ... back to the XMM home page